Intellitype disappeared and wouldn't come back

3 Oktober 2010

Setup:

Windows 7 Ultimate 64 Bit
Microsoft Natural Ergonomic Keyboard 4000 V1.0
Microsoft IntelliType Pro 7.0 installed

The last one is to be able to use the extra keys at the top of the keyboard 

The other day I installed an optional update via Windows Update:

"Microsoft - Other hardware - Microsoft Hardware USB Mouse"

along with some other updates and it installed fine.

However I noticed that the keys at the top of the keyboard are no longer have my user-defined settings.

I opened the keyboard properties via control panel and the tab for the "key Settings" have been gone.
I also noticed that the IType.exe process was not running.

Furthermore there was no trace of IntelliType being installed on the machine.

Ok, I downloaded the latest version of IntelliType (8.0.225.0) but when installing it I got a generic
message with the error code 1603 and the setup failed.

I spend some time researching this online and locally but did not find anything.

C:\Windows\inf\setupapi.dev.log has lots of entries about it but no pointer to want went wrong.

Uninstalling the old version was no option, as it did not show up anywhere.

After searching the registry I found two keys:
HKEY_CURRENT_USER\Software\Microsoft\IntelliType Pro
HKEY_CURRENT_USER\Software\Microsoft\Intellipoint Intellitype Pro Auto Update

I renamed these entries and to my surprise the setup now worked. Even my original key settings are back.

Strange...

Pages in this section

Categories

ASP.Net | Community | Development | IIS | IT Pro | Security | SQL (Server) | Tools | Web | Work on the road | Windows